партнерский раздел
ФорумИнсталляция, монтажПроблемы настройки виртуального порта для работы с C2000-Ethernet

Инсталляция, монтаж » Проблемы настройки виртуального порта для работы с C2000-Ethernet

Доброго времени суток!
Имеется следующая схема:

ПК ->;(ЛВС) ->с2000 Ethernet ->;(RS 232) -> C2000M v3.04 -> (RS 485) -> C2000-2.

Установленное ПО: UPROG 4.1.1 b719 со службой орион2 интерфейс

запускаю SETTINGS, настраиваю COM1 на виртуальный порт, ввожу ип, порт
на с2000Eth настраиваю всё согласно схеме подключения, ип, порты, оставляю свободное подключение по 40001
С2000М настраиваю RS232 на "КОМПЬЮТЕР"
из UPROGа вижу виртуальный порт, выставляю ему тип протокола "Орион про"
делаю опрос - не вижу ничего.

На старой системе(ставилась год назад) настраиваю виртуальный порт и в упроге всё видно.

Если на новой системе через службу орион интерфейс попробовать увидать C2000 Ethernet то всё видно и можно менять настройки, однако виртуальные порты не работают.

Обновление:

Попинал айтишников, выяснил, что были проблемы в сети, но теперь другая проблема:
стоит 3 сигнала20, 1 сигнал 10, при попытке просканировать виртуальный ком порт вижу следующую картину:
появляется "поиск1", после чего зависает упрог секунд на 10 и появляются последние 2 прибора.
Складывается ощущение что слишком быстро комп опрашивает приборы и часть инфы просто не доходит.

1 год 3 месяца назад

avatar
перемычка на эзернете не в конфиге, случаем?

Смирнов Алексей Сергеевич 1 год 3 месяца назад

однозначно не в конфиге. да и со старого всё видно.

areswild 1 год 3 месяца назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

9 ответов

В ядре порт отключаете перед опросом?

1 год 3 месяца назад

avatar
Орион не запущен. но установлен

areswild 1 год 3 месяца назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

1. Я всегда останавливаю ядро опроса перед тем, как зайти в Uprog.
2. Вот здесь посмотрите, может что-то пригодится - 
https://disk.yandex.ru/client/disk/%D0%9E%D1%80%D0%B8%D0%BE%D0%BD
у меня так всё работает нормально.

1 год 3 месяца назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Новая информация: подключил 3 дополнительных виртуальных порта, картина такая же:
нажимаю "опрос" и вижу окно "поиск 1"
после опроса вижу половину приборов. чётные.

1 год 3 месяца назад

avatar
Если Вас не затруднит, выложите сюда скрины своей ситуации, а то не совсем понятно, что Вы там найти не можете.

Герасимов Евгений Вадимович 1 год 3 месяца назад

На старом компе жмём опрос порта, видим: https://prnt.sc/jz0rag
результат после опроса: https://prnt.sc/jz0ued
На новом компе так же https://prnt.sc/jz0vei и https://prnt.sc/jz0w9i
итоговая картина всех портов выглядит так: https://prnt.sc/jz0xlw

почему то картинки не вставляются как картинки

areswild 1 год 3 месяца назад

Вы по моей ссылке (см.выше) смотрели параметры настройки портов?
Это 100% работающая схема.

Герасимов Евгений Вадимович 1 год 3 месяца назад

А можно на другой хостинг залить, например на гугл драйв, а то я в яндекс диске ничего не вижу про орион

areswild 1 год 3 месяца назад

Напишите мне в личке, я постараюсь помочь чем смогу.

Герасимов Евгений Вадимович 1 год 3 месяца назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Переставили Windows на другую и всё заработало. По-крайней мере на одной линии всё считывается нормально, в понедельник будем настраивать остальное.

1 год 3 месяца назад

avatar
Интересно, а каким образом винда могла повлиять на эти процессы?
Кто-нибудь может дать комментарий?

Герасимов Евгений Вадимович 1 год 3 месяца назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Всем привет. Помогите советом подключил по lan порту к компьютеру с2000 ethernet, пытаюсь зайти в него через службу орион 2 интерфейс, а не получается. Выскакивает ошибка (что-то типа нет соединения), хотя я в службе орион 2 интерфейс не чего не менял. 

4 месяца 11 дней назад

avatar
Для подключения «С2000-Ethernet» напрямую к ПК применяется перекрёстный кабель.

Рыбкин Евгений Сергеевич 4 месяца 11 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Я и так использую крос кабель. Дело то в службе орион 2 интерфейс, она не загружается пишет ошибка соединения со службой 

4 месяца 11 дней назад

avatar
Смотрите службу. Запущена ли она.

Рыбкин Евгений Сергеевич 4 месяца 11 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Включена

4 месяца 10 дней назад

avatar
Попробуйте переустановить службу, бывает помогает.

Кечаев Алексей Борисович 4 месяца 10 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Переустанавливал несколько раз. Антивирус касперского удалил, осталось винду Переустанавить 

4 месяца 10 дней назад

avatar
IP адрес ПК какой? и какой у с2000-ethernet?

Рыбкин Евгений Сергеевич 4 месяца 10 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

ПК 192.168.0.103, ETHERNET 192.168.127.254, 192.168.1.202

4 месяца 8 дней назад

avatar
в с2000 пропишите шлюз по умолчанию и в таблице маршрутизации.

Рыбкин Евгений Сергеевич 4 месяца 8 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Добавить ответ

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

ПОКАЗАН

2697 раз

ЗАДАН

1 год 3 месяца назад

По каждому вопросу/ответу можно добавлять комментарии. Комментарии предназначены для уточнения вопроса/ответа.