партнерский раздел
ФорумИнсталляция, монтажОткрытие и закрытие дверей по временному интервалу

Инсталляция, монтаж » Открытие и закрытие дверей по временному интервалу

Доброго времени суток,
Есть С2000-2, С2000-Ethernet, двери на вход/выход, Орион Про 1.20.3
Задача настроить открытие доступа на рабочее время(свободный вход) 8.00 и вход/выход только по пропускам после 17.00.

Создаю 2 окна времени(рабочее и не рабочее время),
Создаю 2 сценария (открыть доступ/восстановить доступ)
В расписании привязываю время со сценарием
В оперативной задаче происходит запуск сценария по заданному времени, но ничего не происходит, двери как работали только по пропускам так и работают.
Прошу помощи....

 

4 месяца 23 дня назад

avatar
Ну вроде все правильно, тяжеловато делать выводы, скиньте хотя бы скрины с АБД, по сценарию, окну времени, расписанию, что пишется в журнале в мониторе? После выполнения сценария, правой кнопкой на ядро опроса, показать, вкладка сценарий, что там написано?

Тремасов Константин Александрович 4 месяца 23 дня назад

https://yadi.sk/i/noUvnRXKPhfQMw
https://yadi.sk/i/l6WAjbz9rue7Cw
https://yadi.sk/i/opkbfPEy8YHBzQ
https://yadi.sk/i/dYiXeRIk17yjYw
https://yadi.sk/i/6bzwIYSg8sO_qw
https://yadi.sk/i/wQqRTn6XE2CN_Q
https://yadi.sk/i/Y2ds6Pl1GzGb8A
https://yadi.sk/i/-Xhw7mIkb1n0ug
 

Аржанов Дмитрий 4 месяца 23 дня назад

Судя по ошибкам, нет такого считывателя, вы когда компьютер указываете, надо выбирать тот к которому подключены приборы, у вас их несколько? Если нет, то пробуйте опять удалить и создать сценарий.

Тремасов Константин Александрович 4 месяца 23 дня назад

компьютер с орионом и к которому настроен ethernet один.
удалять и создавать сценарии пробовал неоднократно...

Аржанов Дмитрий 4 месяца 23 дня назад

Зайдите в настройки самого АБД, там поставьте галку в пункте отображать текст сценариев, перезапустите АБД. Покажите текст сценария и на первой вкладке, приборы по моему называется, свойства этого считывателя, они в испекторе отображаются.

Тремасов Константин Александрович 4 месяца 23 дня назад

я так понимаю это пустой сценарий?
Сценарий
Переменные
Перем РабочееМесто2;
Перем РабочиеМеста2;
Перем Компьютер2;
Перем Компьютеры2;
Перем Считыватель2;
Перем РабочееМесто1;
Перем РабочиеМеста1;
Перем Компьютер1;
Перем Компьютеры1;
Перем Считыватель1;
НачалоСценария


Попытка
Компьютеры1 = СоздатьОбъект( "Компьютеры" );
Компьютер1 = Компьютеры1.ПолучитьПоИд(1);
РабочиеМеста1 = Компьютер1.РабочиеМеста();
РабочееМесто1 = РабочиеМеста1.ПолучитьПоТипуСетевогоМеста("Ядро");
Если не ПустоеЗначение( РабочееМесто1.Считыватели() ) Тогда
Считыватель1 = РабочееМесто1.Считыватели().ПолучитьПоИД( 1 );
Если не ПустоеЗначение( Считыватель1 ) Тогда
Считыватель1.ОткрытиеДоступ();
иначе Сообщить( "Считыватель не найден", 1 );
КонецЕсли;
КонецЕсли;
Исключение Сообщить("Произошло исключение",0); КонецПопытки;

Попытка
Компьютеры2 = СоздатьОбъект( "Компьютеры" );
Компьютер2 = Компьютеры2.ПолучитьПоИд(1);
РабочиеМеста2 = Компьютер2.РабочиеМеста();
РабочееМесто2 = РабочиеМеста2.ПолучитьПоТипуСетевогоМеста("Ядро");
Если не ПустоеЗначение( РабочееМесто2.Считыватели() ) Тогда
Считыватель2 = РабочееМесто2.Считыватели().ПолучитьПоИД( 7 );
Если не ПустоеЗначение( Считыватель2 ) Тогда
Считыватель2.ОткрытиеДоступ();
иначе Сообщить( "Считыватель не найден", 1 );
КонецЕсли;
КонецЕсли;
Исключение Сообщить("Произошло исключение",0); КонецПопытки;
КонецСценария

Аржанов Дмитрий 4 месяца 23 дня назад

Нет, сценарий не пустой, но почему-то ругается на ПолучитьПоИД. Понимаю, если бы руками писали, то да, можно ошибку совершить, но тут шаблоны. Видать глюк программы. Я смогу только завтра проверить на своем ПК. Отпишу.

Тремасов Константин Александрович 4 месяца 23 дня назад

спасибо огромное, буду ждать

Аржанов Дмитрий 4 месяца 23 дня назад

Проверил на своем ПК. Все отрабатывает.
Вы текст сценария который выше просто показали или это ваш сценарий? Даже если бы он работал, то у вас в условиях, первый считыватель открыть, седьмой восстановить, хотя на скринах у вас все разбито на два сценария, так правильно.

Текст моих шаблонов:
Открыть:

Сценарий
Переменные
Перем РабочееМесто1;
Перем РабочиеМеста1;
Перем Компьютер1;
Перем Компьютеры1;
Перем Считыватель1;
НачалоСценария


Попытка
Компьютеры1 = СоздатьОбъект( "Компьютеры" );
Компьютер1 = Компьютеры1.ПолучитьПоИд(1);
РабочиеМеста1 = Компьютер1.РабочиеМеста();
РабочееМесто1 = РабочиеМеста1.ПолучитьПоТипуСетевогоМеста("Ядро");
Если не ПустоеЗначение( РабочееМесто1.Считыватели() ) Тогда
Считыватель1 = РабочееМесто1.Считыватели().ПолучитьПоИД( 1 );
Если не ПустоеЗначение( Считыватель1 ) Тогда
Считыватель1.ОткрытиеДоступ();
иначе Сообщить( "Считыватель не найден", 1 );
КонецЕсли;
КонецЕсли;
Исключение Сообщить("Произошло исключение",0); КонецПопытки;
КонецСценария

Восстановить:

Сценарий
Переменные
Перем РабочееМесто1;
Перем РабочиеМеста1;
Перем Компьютер1;
Перем Компьютеры1;
Перем Считыватель1;
НачалоСценария


Попытка
Компьютеры1 = СоздатьОбъект( "Компьютеры" );
Компьютер1 = Компьютеры1.ПолучитьПоИд(1);
РабочиеМеста1 = Компьютер1.РабочиеМеста();
РабочееМесто1 = РабочиеМеста1.ПолучитьПоТипуСетевогоМеста("Ядро");
Если не ПустоеЗначение( РабочееМесто1.Считыватели() ) Тогда
Считыватель1 = РабочееМесто1.Считыватели().ПолучитьПоИД( 1 );
Если не ПустоеЗначение( Считыватель1 ) Тогда
Считыватель1.ВосстановитьДоступ();
иначе Сообщить( "Считыватель не найден", 1 );
КонецЕсли;
КонецЕсли;
Исключение Сообщить("Произошло исключение",0); КонецПопытки;
КонецСценария

 

Тремасов Константин Александрович 4 месяца 22 дня назад

это мой сценарий на две двери на открытие

Аржанов Дмитрий 4 месяца 22 дня назад

А, не, походу я в свой смотрел))) в вашем все нормально) Но что-то не нравится программе.
Попробуйте мой скопировать, и создать не на основе шаблонов. Чисто ради эксперемента, потом под второй считыватель допилим, если начнет работать.


 

Тремасов Константин Александрович 4 месяца 22 дня назад

если просто скопировать, и создать сценарий не на основании шаблона, то попробовал - не работает

Аржанов Дмитрий 4 месяца 22 дня назад

Покажите свойства считывателя, первая вкладка, приборы, разверните древо приборов, покажите инспектор этих считывателей, конкретно интересует пользовательский номер этих считывателей. Только не кусок инспектора, а чтоб было видно считку в древе, адрес прибора и прочее с инспектором.

Тремасов Константин Александрович 4 месяца 22 дня назад

добрый день
https://ibb.co/q9ZG8qv
https://ibb.co/RjPWmSk
https://ibb.co/2jdpCYS
https://ibb.co/PZgXSMb
https://ibb.co/HrSN6k8
 

Аржанов Дмитрий 4 месяца 16 дней назад

На последнем скрине, инспектор рабочего места, указан IP адрес 127.0.0.0, укажите 127.0.0.1, обновите БД в ОЗ, а лучше перезапустите все модули. Попробовал воспроизвести ситуацию, IP 127.0.0.1 - сценарии отрабатывают, IP 127.0.0.0 - сценарий даже не запускается, АРМ 1.20.3 sp1.

P.S. 127.0.0.1 это локальный компьютер, можете вместо 127.0.0.1 указать явный IP который присвоен вашей сетевой карте.

Тремасов Константин Александрович 4 месяца 16 дней назад

да, все верно, все работает. ОГРОМНОЕ СПАСИБО!

Аржанов Дмитрий 4 месяца 15 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

2 ответа

Вот в помощь кстати https://partners.bolid.ru/forum/forum_17113.html
Вариант рабочий, и решение одной проблемы описано.

4 месяца 22 дня назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

У меня не работало, пока орион сервер не перезапустишь. После правок сценариев тоже перезапускать надо.

4 месяца 21 день назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Добавить ответ

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

ПОКАЗАН

890 раз

ЗАДАН

4 месяца 23 дня назад

По каждому вопросу/ответу можно добавлять комментарии. Комментарии предназначены для уточнения вопроса/ответа.