партнерский раздел
ФорумИнсталляция, монтажПри установленной ОрионПро Uprog не видит приборов по RS485USB

Инсталляция, монтаж » При установленной ОрионПро Uprog не видит приборов по RS485USB

Добрый день! С Днем Победы!

Конфигурю на столе комп для работы с ОрионПро. Windows10RUS лицензия, ОрионПро 1.20.3 (вообщем все свежее ссайта). Для "настольной" конфигурации использую RS-485USB с драйвером с сайта (выставлены настройки порта 9600/8/N/1, RS-485 ). Служба Orion2. Device interface Protocol в службах бежит. При попытке поиска приборов UPROG 4.1.4b5610 он ничего не находит - подключен С2000-2 v1.02 (да, старенький- для экспериментов), протокол передачи 9600, Болид.
На ДРУГОМ компьютере с такими же виндой/драйвером и настройками этот же uPROG видит ЭТОТ прибор на 14 адресе и позволяет его конфигурить. Т е железная часть системы - рабочая.
При добавлении контроллера в АБД Орион Про (адрес-то я знаю) - он остается серым, связи нет. Что нужно настроить чтобы АБД работала с Uprog ? Куда копать? Честно, ОрионПро ставлю в первый раз)).
 

2 месяца 25 дней назад

avatar
Для начала надо посмотреть в диспетчере устройств этот преобразователь и свойствах, если есть галка RS485, то поставить её, если нет, то пропускаем этот шаг. Далее, программы по очереди должны работать, если открыт uprog и ядро опроса, будет конфликт. 

Тремасов Константин Александрович 2 месяца 25 дней назад

Это, угу, для про лучше бы 232 использовать.

Леготин В В 2 месяца 25 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

5 ответов

Спасибо. В том то все и дело - галка RS485 стоит, запущен только UProg (никаких доп программ) - прибор не видит. (при опросе из uProg светодиод на преобразователе моргает - т е порт указан верно).

2 месяца 25 дней назад

avatar
Да, тогда поподробнее. Количество приборов, видятся ли по отдельности с бука, отсечь лишнии сущносьти.

Леготин В В 2 месяца 25 дней назад

А сам порт в  Uprog как настроен на этом компе? Нужен протокол Орион, 9600. У вас часом там М не стоит в промежутке между портом и прибором? Надо тогда М в программирование перевести. А, еще можно попробовать uprog от имени одмена запустить.

Тремасов Константин Александрович 2 месяца 25 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Комп сейчас подключен на столе только к одному единственному контроллеру С2000-2 v1.02. резистор на конце линии включен. В качестве интерфейса - RS-485USB с драйвером с сайта (выставлены настройки порта 9600/8/N/1, RS-485). Просто перетыкаю RS-485USB в ноутбук с таким же uProg - все видится, т е железная часть рабочая. В обоих uProg выставлен протокол связи  Орион/9600.

2 месяца 25 дней назад

avatar
Ладно, контроллер вобще не нужен, откидываем его. Нет приборов при опросе юпрогом? Проблема в железе или в софте? Подменный комп есть?

Леготин В В 2 месяца 25 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Решено!

Вытащил из USB лицензионные ключи от АБД и ОЗ... Заработало.
Вставил обратно - работает.
В Мониторе ОЗ "взлом корпуса" показывает (при отпускании концевака) - т е с ОЗ тоже связь пошла

Какой-то глюк с драйверами  guardant

2 месяца 25 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Добрый день!

Вот уже много лет использую ваш свисток как преобразователь USB - RS485 в стороннем оборудовании для програмирования промконтролеров по протоколу Modbus-RTU. Но с сентября 19 года по май 20 года произошли какие-то критические обновления для операционной системы, после которых преобразователь не правильно работает. Выдает ошибку работы на СОМ порту. Откат Системы до версии Сентября 19 года. устраняет проблему. Т.е. проблема кротся в драйверах. Антивирус отключал.
 
P.S. устанавливал на ноут от Lenova. пробывал на Samsung с ОС 7 тоже не хочет работать.

2 месяца 2 дня назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Здравствуйте. Не до конца устанавливаются драйвера на крм порт. Windows 7.
В диспетчере устройств появляется устройство, назначается номер порта. На картинке устройства жёлтая метка. В свойствах драйверов пишет, что устройство не имеет цифровой подписи, поэтому .... в общем работать не будет.
На другом компе тоже с ВИН 7 где есть доступ в интернет драйвера установились из центра обновления виндовс автоматически и всё работает.

1 месяц 29 дней назад

avatar
устройство не имеет цифровой подписи, поэтому .... в общем работать не будет.

а если временно отключить проверку подписи?

Волков Андрей 1 месяц 28 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Добавить ответ

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

ПОКАЗАН

857 раз

ЗАДАН

2 месяца 25 дней назад

По каждому вопросу/ответу можно добавлять комментарии. Комментарии предназначены для уточнения вопроса/ответа.