партнерский раздел
ФорумИнсталляция, монтажПри установленной ОрионПро Uprog не видит приборов по RS485USB

Инсталляция, монтаж » При установленной ОрионПро Uprog не видит приборов по RS485USB

Добрый день! С Днем Победы!

Конфигурю на столе комп для работы с ОрионПро. Windows10RUS лицензия, ОрионПро 1.20.3 (вообщем все свежее ссайта). Для "настольной" конфигурации использую RS-485USB с драйвером с сайта (выставлены настройки порта 9600/8/N/1, RS-485 ). Служба Orion2. Device interface Protocol в службах бежит. При попытке поиска приборов UPROG 4.1.4b5610 он ничего не находит - подключен С2000-2 v1.02 (да, старенький- для экспериментов), протокол передачи 9600, Болид.
На ДРУГОМ компьютере с такими же виндой/драйвером и настройками этот же uPROG видит ЭТОТ прибор на 14 адресе и позволяет его конфигурить. Т е железная часть системы - рабочая.
При добавлении контроллера в АБД Орион Про (адрес-то я знаю) - он остается серым, связи нет. Что нужно настроить чтобы АБД работала с Uprog ? Куда копать? Честно, ОрионПро ставлю в первый раз)).
 

19 дней 18 часов назад

avatar
Для начала надо посмотреть в диспетчере устройств этот преобразователь и свойствах, если есть галка RS485, то поставить её, если нет, то пропускаем этот шаг. Далее, программы по очереди должны работать, если открыт uprog и ядро опроса, будет конфликт. 

Тремасов Константин Александрович 19 дней 18 часов назад

Это, угу, для про лучше бы 232 использовать.

Леготин В В 19 дней 18 часов назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

3 ответа

Спасибо. В том то все и дело - галка RS485 стоит, запущен только UProg (никаких доп программ) - прибор не видит. (при опросе из uProg светодиод на преобразователе моргает - т е порт указан верно).

19 дней 18 часов назад

avatar
Да, тогда поподробнее. Количество приборов, видятся ли по отдельности с бука, отсечь лишнии сущносьти.

Леготин В В 19 дней 18 часов назад

А сам порт в  Uprog как настроен на этом компе? Нужен протокол Орион, 9600. У вас часом там М не стоит в промежутке между портом и прибором? Надо тогда М в программирование перевести. А, еще можно попробовать uprog от имени одмена запустить.

Тремасов Константин Александрович 19 дней 18 часов назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Комп сейчас подключен на столе только к одному единственному контроллеру С2000-2 v1.02. резистор на конце линии включен. В качестве интерфейса - RS-485USB с драйвером с сайта (выставлены настройки порта 9600/8/N/1, RS-485). Просто перетыкаю RS-485USB в ноутбук с таким же uProg - все видится, т е железная часть рабочая. В обоих uProg выставлен протокол связи  Орион/9600.

19 дней 17 часов назад

avatar
Ладно, контроллер вобще не нужен, откидываем его. Нет приборов при опросе юпрогом? Проблема в железе или в софте? Подменный комп есть?

Леготин В В 19 дней 17 часов назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Решено!

Вытащил из USB лицензионные ключи от АБД и ОЗ... Заработало.
Вставил обратно - работает.
В Мониторе ОЗ "взлом корпуса" показывает (при отпускании концевака) - т е с ОЗ тоже связь пошла

Какой-то глюк с драйверами  guardant

19 дней 17 часов назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Добавить ответ

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

ПОКАЗАН

325 раз

ЗАДАН

19 дней 18 часов назад

По каждому вопросу/ответу можно добавлять комментарии. Комментарии предназначены для уточнения вопроса/ответа.