партнерский раздел
ФорумИнсталляция, монтажПроблема с взятием/снятием раздела на БКИ

Инсталляция, монтаж » Проблема с взятием/снятием раздела на БКИ

Добрый день!
Есть система: АРМ "Орион" 1.12.2 (Протокол "Орион ПРО" - Пульт С2000м ver.2.06 (компьютер) (подключенный по RS-232 к АРМ) - С2000-Ethernet(Slave) (подключен к пульту по RS-485) - C2000-Ethernet (Master) - Приборы (по RS-485) - С2000-БКИ.
* Все С2000-Ethernet в режиме (сохранение событий).

Проблема следующая:
На объекте 4 здания (ЛВС-оптика). В трех зданиях С2000- Ethernet(Master).В четвертом С2000-Ethernet(Slave). Все в одной подсети, с передачей инфы на С2000-Ethernet(Slave), затем на пульт, пульт в Орион ПРО.
Была проблема с С2000-Ethernet(Master) в одном здании. Переставил с другого здания временно. Все работает, за исключением БКИ! Не хочет управлять разделами никак. Поставил С2000-К рядом, чтобы хоть как то управлять разделами. До отвала с2000-Ethernet (Master), БКИ работал исправно (брал, снимал).

Сам БКИ состояния разделов показывает. При попытке управления разделами с БКИ ячейка теперь просто моргает несколько секунд и все. На пульте никакой реакции. Будто нет разрешения управления разделом. Но такого быть не может т.к.:
1) раньше работал;
2) проверял конфиг пульта. Привязка разделов к БКИ. Пароль в БКИ вписан. Этим же паролем с с2000м и с2000-к ставится и снимается раздел;
3) В орион про считан конфиг с пульта. так что конфликта АБД и с2000м быть не может.


Еще грешу на проведенную манипуляцию с RS-485.
Раньше работало все без пульта. Т.е. Орион ПРО (протокол "Орион") - USB-RS-485 - С2000-Ethernet (Slave) - C-2000-Ethernet (Master) - Приборы - БКИ
При аварии, пока искал причину, добавил с2000-м с RS-232 в систему и перевел все на него. Также С2000-Ethernet(Master)(замененный) находился в здании с этим БКИ. Линия RS-485 шла по двум парам витой пары (первая-основная, вторая-резервная), так что ничего как мне кажется не изменилось, т.к. все работает как прежде, кроме БКИ.

Подскажите куда копать, а то уже месяц не могу его победить.
Уже пробовал:
1) С2000-ПИ (в режиме продолжителя интерфейса) после С2000-Ethernet (Master)(замененного) поставить;
2) вторую пару RS-485 на БКИ добавить;
3) пульт С2000-М поменять на ver.2.05;
4) откидывал все приборы от С2000-Ethernet (Master), кроме БКИ;
5) брал с другого здания БКИ. Вот тут интересно! В одном здании этот БКИ управляет разделами, а в том, где был заменен c2000-Ethernet (Master), не хочет управлять! И проблемный БКИ также (в одном здании управляет разделами, а в проблемном здании нет). Но я проверял это до С2000-Ethernet (Slave) (т.е. у пульта). Поэтому насчет работоспособности БКИ после С2000-Ethernet(Slave) не уверен.
6) Добавлял брелок ТМ в систему, чтобы управлять разделами с БКИ (пароль считывается, ожидает команд, нажимаешь кнопку(ячейку) и ничего не происходит (поморгает и все)). Этот же брелок управляет разделами с другого БКИ (в здании с пультом)

Может проблемы с паузами и ожиданиями в с2000-Ethernet-ов(Master, т.к. был перенесен в другое здание) или (Slave). Но думаю, что нет. т.к. расстояние ЛВС отличается незначительно (~50м, что для оптики вообще не чувствуется)). А вот насчет увеличения расстояния RS-485 от пульта я не уверен (но как тогда все работает как надо (с 2000-к все управляется), а с БКИ нет?)

При попытке взятия/снятия раздела через БКИ (в проблемном здании) на пульте никакой реакции, а в оперативной задаче, в логах, событие "Реакция оператора" (прибор - БКИ).
Т.е. получается, если ДО С2000-Ethernet (Slave) ставить/снимать раздел с пульта или БКИ, то все работает на правах "Владельца", но если с этим же паролем пробовать с БКИ ПОСЛЕ С2000-Ethernet (Slave), то система думает что это пароль "Оператора", а если с пульта, то все работает на правах "Владельца". Я так предполагаю...
Чтобы это значило?
Уже незнаю, что думать... может что-то полетело в С2000-Ethernet (Slave) или (Master)? Может в конфиге Ethernet-ов что-то надо править после реконструкции? Все же работало (до аварии) без пульта по RS-485, а теперь главный - пульт на RS-232 и от него пошел RS-485!
Вообще, кто может рассчитать тайминги с паузами для Slave и Master Ethernet-ов, и RS-485Settings, и Settings.exe?
Пульт - один Slave - 3 Master - БКИ.
Ping менее 1 мсек на всех Ethernet-ах!
Уже попробовал выставить тайминги в пульте и в АРМ как для десяти Ethernet-ов в системе (согласно рекомендации по настройке RS-485 для С2000-Ethernet).

2 месяца назад

avatar
Переведи Ethernet  в прозрачный режим. 
И пульт желательно обновить до 2.08

Морковкин Сергей Михайлович 1 месяц 24 дня назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

0 ответов

Добавить ответ

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

ПОКАЗАН

705 раз

ЗАДАН

2 месяца назад

По каждому вопросу/ответу можно добавлять комментарии. Комментарии предназначены для уточнения вопроса/ответа.