партнерский раздел
ФорумЭксплуатацияСценарий для задержки доступа

Эксплуатация » Сценарий для задержки доступа

Добрый день, коллеги!
Бьюсь неделю с такой проблемой: имеется помещение с 2мя дверями, со считывателями у каждой двери, с каждой стороны. Нужно сделать такой сценарий: при закрытии любой из этих дверей - запрет на вход в течении заданного времени. 
Пробовал временной антипасбек, добавлять задержку в шаблонном сценарии на разблокировку считывателей по событию закрытия двери - ниче не работает (

8 месяцев 4 дня назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

4 ответа

Вот пример сценария, когда по событию закрытия двери разблокируются считыватели, и здесь я добавлял задержку 10сек (выделил красным) ожидая задержку на разблокирование. Но это не работает.

Сценарий
Переменные
Перем Считыватель2;
Перем Компьютеры2;
Перем Компьютер2;
Перем РабочиеМеста2;
Перем РабочееМесто2;
Перем Считыватель1;
Перем Компьютеры1;
Перем Компьютер1;
Перем РабочиеМеста1;
Перем РабочееМесто1;
НачалоСценария


Попытка
Компьютеры1 = СоздатьОбъект( "Компьютеры" );
Компьютер1 = Компьютеры1.ПолучитьПоИд(1);
РабочиеМеста1 = Компьютер1.РабочиеМеста();
РабочееМесто1 = РабочиеМеста1.ПолучитьПоТипуСетевогоМеста("Ядро");
Если не ПустоеЗначение( РабочееМесто1.Считыватели() ) Тогда
Считыватель1 = РабочееМесто1.Считыватели().ПолучитьПоИД( 321 );
Если не ПустоеЗначение( Считыватель1 ) Тогда Задержка ( 10000 );
Считыватель1.ВосстановитьДоступ();
иначе Сообщить( "Считыватель не найден", 1 );
КонецЕсли;
КонецЕсли;
Исключение Сообщить("Произошло исключение",0); КонецПопытки;

Попытка
Компьютеры2 = СоздатьОбъект( "Компьютеры" );
Компьютер2 = Компьютеры2.ПолучитьПоИд(1);
РабочиеМеста2 = Компьютер2.РабочиеМеста();
РабочееМесто2 = РабочиеМеста2.ПолучитьПоТипуСетевогоМеста("Ядро");
Если не ПустоеЗначение( РабочееМесто2.Считыватели() ) Тогда
Считыватель2 = РабочееМесто2.Считыватели().ПолучитьПоИД( 322 );
Если не ПустоеЗначение( Считыватель2 ) Тогда Задержка ( 10000 );
Считыватель2.ВосстановитьДоступ();
иначе Сообщить( "Считыватель не найден", 1 );
КонецЕсли;
КонецЕсли;
Исключение Сообщить("Произошло исключение",0); КонецПопытки;
КонецСценария

8 месяцев 4 дня назад

avatar
когда по событию закрытия двери разблокируются считыватели

не ясно, а что тогда дверь блокирует? что потом надо её разблокировать.

Волков Андрей 8 месяцев 4 дня назад

Простой сценарий, на блокирование считывателей по событию "открытие двери"

Архипов Александр Сергеевич 8 месяцев 4 дня назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Изначально, было так:
одна дверь открывается, и пока она открыта - блокировка считывателей другой двери. Когда открытая дверь закрылась, происходит разблокировка двери. Вот в эту логику я лишь хотел добавить задержку на разблокирование считывателей.

8 месяцев 3 дня назад

avatar
Если  шс на С2002 сделать охранным  и в Упрог вставить автоперевзятие из тревоги  выставить задержку взятия на нужное Вам  время и написать в сценарии шс взялся доступ предоставлен шс нарушен доступ закрыт 

Ахтямов Михаил Владимирович 8 месяцев 3 дня назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

может быть поможет блокировка по BUSY и датчику присутствия (коротить этот сигнал на GND на время чем-нибудь)

8 месяцев 2 дня назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Решил проблему. В скрипте задержку нужно указывать после перечисления желаемых действий 1 раз. Тогда работает система корректно. Остался вопрос, как изолировать эту задержку, что бы можно было писать действия и на другие двери тоже. Это пока не знаю как реализовать.

8 месяцев 2 дня назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Добавить ответ

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

ПОКАЗАН

776 раз

ЗАДАН

8 месяцев 4 дня назад

ПРОДУКТЫ

Орион Про
С2000-2

По каждому вопросу/ответу можно добавлять комментарии. Комментарии предназначены для уточнения вопроса/ответа.