партнерский раздел
ФорумИнсталляция, монтажОрион Про не работает на скорости 115200

Инсталляция, монтаж » Орион Про не работает на скорости 115200

Здравствуйте, у нас на объекте стоят несколько С2000М, подключенный к компу через несколько ПИ (схема). Также установлен ОрионПро. Вся эта система работает на скоростях 9600 и в настройках АБД и в настройках Pprog. Попытались перевести все это на скорости 115200, но в итоге все перестало работать. А конкретно АБД при считывании стала выдавать ошибку "invalid playload received from xml-rpc server", а Pprog перестал считывать как в режиме прогграммирования, так и в не режима программирования. В итое перевели все обратно на 9600 и все стало работать.
Как было точно и что было сделано:

1. В COM-порте компьютера в диспетчере устройств непосредственно стояла скорость 9600 - поставили 115200
2. В настройках АБД стояла скорость 9600. Тип ПИ стояло С2000ПИ - поставили скорость  115200
3. В утилите "Настройки RS" ОрионПро. Стояла скорость 9600. Тип ПИ - ПИ-ГР и протокол Орион - поставили 115200, поменяли тип ПИ на С200ПИ, а протокол на ОрионПро
4. В пульте скорость стояла 9600 - поставили 115200
5. Адрес 232 и 485 в С2000М одинаковый. Версия пульта 4.12

 

3 месяца 16 дней назад

avatar
А в приборах С2000-ПИ скорость изменили перемычками?

Кузьминов Сергей Владимирович 3 месяца 16 дней назад

Нет. Надо ж так забыть...А то, что при выборе в pprog режим ОрионПро и скорость 115200 ничего не происходит, то есть даже медленное считывание на 9600 перемычка тоже может повлиять?

Ропшинский Иван 3 месяца 16 дней назад

Я конечно не использую С2000-ПИ, у меня пульт напрямую на com-порт ПК подключен, но скорость 115200 выставлял только в самом пульте, ОрионПРО и в программе "Настройка опроса (Settings)", настройки самого com-порта в диспетчере устройств я не трогал. Попробуйте все же восстановить там настройки по умолчанию и проверить.

Бабаев М. А. 3 месяца 15 дней назад

Настройки скорости порта в диспетчере устройств я увеличил до 115200, и в таком виде работает, это как минимум не мешает. 

Иванов Андрей Львович 3 месяца 15 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

1 ответ

Наверное, разгон надо начинать со скорости 19200. У меня и на такой скорости как-то были глюки, вернул на 9600

3 месяца 16 дней назад

avatar
Это что новое. Такой информации в инструкции нет. Сам производитель рекомендует ставить сразу 115200. Не магнитные же бури влияют на это...

Ропшинский Иван 3 месяца 16 дней назад

На месте производителя я бы поостерёгся рекомендовать такое, потому что производитель не знает ни длины кабеля у потребителя, ни электромагнитной обстановки вдоль кабеля у потребителя. Я допускаю, что производитель может рекомендовать 115200 только при обязательном использовании штатного кабеля АЦДР, потому что он короткий, и вдоль этого метра явно не будут танцевать электросварщики. 

Иванов Андрей Львович 3 месяца 15 дней назад

Сам производитель рекомендует ставить сразу 115200

Так надо же на условия смотреть. 115200 надёжно работает на линии метров 10 между двумя устройствами, а у Вас там куча ПИ и куча линий, каждая вносит помехи, ещё неизвестно, как 485я линия затерминирована, там и на 19200 может не работать.

Русаков Владимир 3 месяца 9 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Добавить ответ

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

ПОКАЗАН

711 раз

ЗАДАН

3 месяца 16 дней назад

По каждому вопросу/ответу можно добавлять комментарии. Комментарии предназначены для уточнения вопроса/ответа.