партнерский раздел
ФорумИнсталляция, монтажC не работает компорт

Инсталляция, монтаж » C не работает компорт

Добрый день, на объекте 5 пультов, привезли комп в нем 6 компортов, два из них подписаны а диспетчере устройство как high speed pci serial port, а остальные 4  как pci - isa communication port. Пульт с 2000м подключаю напрямую к порту, причём через первые два ком порта работает, а через остальные четыре нет.. Крышку, снять не могу, плата расширения на компорты одна на 6 компортов, в чем может быть проблема? 

2 года 3 месяца назад

avatar
Драйвера мб?

Шапран Сергей 2 года 3 месяца назад

Ну драйвер же один на всю плату 

Меркуль Игорь Юрьевич 2 года 3 месяца назад

Нет, как правило, расширители СОМ идут на 2 или 4 порта, втыкаются в PCI. Так что может статься, что на тот расширитель не установлены драйвера. 

Шапран Сергей 2 года 3 месяца назад

Переустановил драйвер, один драйвер идёт сразу на 6 портов, опять же 2 работает,  4 нет 

Меркуль Игорь Юрьевич 2 года 3 месяца назад

Странная плата у Вас=\ я с такими не встречался. У меня, кстати, pci-isa communication очень даже работает. Может настройки самого СОМ порта?

Шапран Сергей 2 года 3 месяца назад

Там все по умолчанию стоит особо настроек нету 

Меркуль Игорь Юрьевич 2 года 3 месяца назад

Я бы тоже на драйвер грешил. Возможно качнул с сайта что есть (может баг в дровах на диске)

Иванков Сергей Николаевич 2 года 3 месяца назад

Уже раз 5 драйвера с разных источников установил, все тоже самое 

Меркуль Игорь Юрьевич 2 года 3 месяца назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

3 ответа

Устройство orient xwt PS 56

2 года 3 месяца назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

в Настройках каждого порта должна быть вкладка Advanced где выбирается режим работы RS-232/RS-422/RS-485. Сравните настройки у работающих портов и не работающих.

2 года 3 месяца назад

avatar
В тех портах, что работают, есть такая вкладка, в других в эдвансд другие настройки, типо использовать буфер FIFO 

Меркуль Игорь Юрьевич 2 года 3 месяца назад

Попробуйте установить драйвера вручную.
Обновить драйвер, выполнить поиск драйверов на компьютере, выбрать драйвер из списка ужк установленных
выберите там драйвер для  high speed pci serial port, или укажите путь до папки с этими драйверами.

Рыбкин Евгений Сергеевич 2 года 3 месяца назад

Попробовал, поймал синий экран смерти, помогла только последняя успешная загрузка) 

Меркуль Игорь Юрьевич 2 года 3 месяца назад

Это может быть как - то связана с irq,  на этих портах iqr 17

Меркуль Игорь Юрьевич 2 года 3 месяца назад

Ну раз на это грешите попробуйте изменить значение в BIOS PnP(Plug and Play O/S) в биосе Yes-операционная система занимается распределением ресурсов, NO- BIOS. 

Богданюк Дмитрий Владимирович 2 года 3 месяца назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

С расширителями часто проблемы возникают. У меня тоже тут стоит ST Lab на 4 com-порта. Два работают, а два нет, просто не открываются, вин 7 ошибку выдает. И у меня такое не первый раз на разных компьютерах. Причем работают те два, которые расположены (запаяны) прямо на плате расширения. А те, что на шлейфах подключаются - не работают. В чем причина - не понятно.

2 года 3 месяца назад

avatar
Тоже самое, что запаяны только работают. Но у меня открываются, но приборы не видит, если тот же самый шнурок воткнуть в рабочий ком порт, то приборы находятся 

Меркуль Игорь Юрьевич 2 года 3 месяца назад

Там может быть шлейф, соединяющий дополнительные СОМы с платой вставлен не правильно-было у меня такое один раз. 

Шапран Сергей 2 года 3 месяца назад

Там, как правило, защита сделана - неправильно не подключишь. Хотя, кто знает, надо поглядеть.

Назаретский Сергей Алексеевич 2 года 3 месяца назад

Я смотрел, вставлены шлейфом во внутрь, как на картинке, защиты нету 

Меркуль Игорь Юрьевич 2 года 3 месяца назад

В том и дело, что защиты нет-я даже удивился, когда с этим столкнулся. 

Шапран Сергей 2 года 3 месяца назад

Некогда мне сейчас комп вскрывать, я так и двумя портами обхожусь + С2000-USB. Но хочу предупредить, если будете шлейфы перетыкать - обязательно при выключенном компьютере. COM-порты сильно склонны к выгоранию...
Но в своей плате я еще заметил, что драйвера на порты разные. Мне кажется, что проблема может глубже сидеть...

Назаретский Сергей Алексеевич 2 года 3 месяца назад

Сделал наконец-то, 
Шлейфа не правильно воткнуты в плату, ну тоесть они были воткнуты как на картинке на сайте и на коробке, но по итогу надо было наоборот 
http://www.orientrus.ru/uploads/thumb/279_740.jpg
 

Меркуль Игорь Юрьевич 2 года 3 месяца назад

Победа=)

Шапран Сергей 2 года 3 месяца назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Добавить ответ

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

ПОКАЗАН

2076 раз

ЗАДАН

2 года 3 месяца назад

По каждому вопросу/ответу можно добавлять комментарии. Комментарии предназначены для уточнения вопроса/ответа.