партнерский раздел
ФорумИнсталляция, монтажАРМ про и C2000-Ethernet

Инсталляция, монтаж » АРМ про и C2000-Ethernet

0

Который день пытаюсь запустить работу системы АРМ про с преобразователем интерфейса C2000-Ethernet.
Задача простая управлять системой СКУД с удаленного сервера(через LAN)
Я настроил C2000-Ethernet в прозрачный режим, создал виртуальный СОМ порт (программка settings), но приборов за преобразователем не вижу.
C2000-Ethernet через uprog прекарсно конфигурируется,

Режим работы: прозрачный
Тип интерфейса: RS485
Тип протокола: Орион
Адрес: 127
ко-во стоп бит: 1
Пауза между посылками 10

Приборы подключены по 485 интерфейсу (первый прибор подключенный к преобразователю - С2000-2)
Перемычка в режиме Pass.
Горят лампочки wrk и eth.
Может нужно не в прозрачном режиме его натсраивать????

5 месяцев 26 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

8 ответов

0

5 месяцев 26 дней назад

avatar

кстати, а почему Тип ПИ - С2000-ПИ? я везде выставляю ПИ-ГР и оно как-то работает

Волков Андрей 5 месяцев 25 дней назад

Да оно и так и так работает, я по привычке ставлю. Так же в settings выбирается тип протокола Орион или Орион ПРО, но как выяснилось, он не влияет Uprog всегда опрашивает в протоколе Орион. PProg в том протколе, который указан в интерфейсе программы pprog "настройка/последовательный порт/порт/вкладка протокол". Протокол работы АРМ Орион Про будет зависеть от структуры базы данных (если добавлен пульт на COM, то протокол Орион Про; а если приборы Орион на COM, то протокол Орион).– Ольга 9 месяцев 25 дней назад

Может и с преобразователем те же телега.

Тремасов Константин Александрович 5 месяцев 25 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

0

Удалось наконец-то увидеть список всех доступных приборов в uprog, но при попытке считать конфигурацию из любогго из них вылезает сообщение Ошибка связи по интерфейсу "Прибор не отвечает. Подождать?". что с этим делать? версия Uprog 4.1.0.60 

5 месяцев 25 дней назад

avatar

Настройки виртуального порта в Settings покажите.

Тремасов Константин Александрович 5 месяцев 25 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

0

 вот скрин

5 месяцев 25 дней назад

avatar

Не открывается.

Тремасов Константин Александрович 5 месяцев 25 дней назад


Не научился человек еще картинки вставлять)

Смирнов Алексей Сергеевич 5 месяцев 25 дней назад

не понятно просто как это делать(

Романов Алексей 5 месяцев 25 дней назад

Судя по всему мастером настройки пользовались?

Вот такие настройки попробуйте, при условии что ping до Ethernet не превышает 10 мс.


 

Тремасов Константин Александрович 5 месяцев 25 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

0

не помогает

5 месяцев 25 дней назад

avatar

А у вас самая последняя версия упрог из темы https://partners.bolid.ru/forum/forum_8414.html ? Если нет, то действительно, возможны ошибки.

Богачева Н.В. 5 месяцев 25 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

0

она самая

5 месяцев 25 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

0

при чем на тестовом стенде с теми же настройками все работает!!!!

5 месяцев 25 дней назад

avatar

ping какой на тестовом и на объекте?

Тремасов Константин Александрович 5 месяцев 25 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

0

что там что там 5мс

5 месяцев 25 дней назад

avatar

Значит на столе все норм, на объекте нет. Может там по сети какая-то проблема? Скиньте конфиг (выложить в облако, дать общий доступ и ссылку сюда) вашего Ethernet c настройками объекта.

Тремасов Константин Александрович 5 месяцев 25 дней назад

отнес систему со "стола" воткнул в туже сеть, расстояние - не помеха. Поменял светевые преобразователи местами - тот что был на "столе" воткнул в сисетму, он как и основоной перестал отдавать приборы, или выдает ошибки. Тот что был в системе прекрасно увидел "столовый" контроллер.....

Романов Алексей 5 месяцев 25 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

0

может быть проблема в С2000-2??? он кстати подключен через 232 шину к серверу системы( на другом компьютере) может быть в этом проблема?

5 месяцев 25 дней назад

avatar

откуда в С2000-2 появилась 232 шина? О_о или это так преобразователь из 485 в 232 называется?

Волков Андрей 5 месяцев 25 дней назад

А вот с этого момента поподробнее.

Тремасов Константин Александрович 5 месяцев 25 дней назад

ну в общем этот же контроллер подключен к центральному серверу сисетмы Орион Про через преобразоватлеь 485->232( COM порт), я параллельно пытаюсь зацепиться, чтобы систему виртуалицировать. сервер перенести в вирт среду.

Романов Алексей 5 месяцев 25 дней назад

Т.е. С2000-2 опрашивается одновременно с двух мест? Если так, то его надо отключить от сервера, в системе может быть только одно "мастер" устройство, которое опрашивает остальные приборы.

Тремасов Константин Александрович 5 месяцев 25 дней назад

Короче я ошибся, отключив контроллер от сервера, я получил ту же картину. Но обратил внимание на то, что горит лампочка 485 интерфейса на С2000-ethernet, горит постоянно, хотя прибор я не опрашиваю. Оказалось что слаботочник подключил прибор не к тому контроллеру. точнее даже не к контроллеру а к пульту С2000М. который как я и говрил подключен к компу через 232 интерфейс. меня еще тогда удивило что 232 без преобразователя в 485.... ??!!?!?!?!?!!? Сегодня все переделает опишу результат.

Романов Алексей 5 месяцев 18 дней назад

Преобразователь к пульту зацепили по 232 интерфейсу... приборов он не видит.... настройки поменял на 232 и протокол Орион Про. надо в settings что-то менять? или только преобразователь???

Романов Алексей 5 месяцев 18 дней назад

Пульт в режиме "Компьютер", если с АРМ пытаетесь найти или в режиме программирования если с uprog.

Тремасов Константин Александрович 5 месяцев 18 дней назад

пульт в режиме Компьютер должен быть по словам слаботочника. Т.е. С УПРОГ я ни чего не должен увидеть??

Романов Алексей 5 месяцев 18 дней назад

Есть на форуме тестовая версия uprog она позволяет увидеть приборы за пультом при условии что к пульту подключен ПК по 232 и пульт в режиме компьютер. Другие версии uprog этого сделать не позволяют, надо переводить пульт в режим программирования.

Тремасов Константин Александрович 5 месяцев 18 дней назад

где хоть искать эту тествоую версию? или версию ее???

Романов Алексей 5 месяцев 17 дней назад

https://partners.bolid.ru/forum/forum_8414.html

Богачева Н.В. 5 месяцев 17 дней назад

Подскажите пожалуйста как мне поступить? Пульт в режиме компьютер, к нему подключен c2000-ethernet в прозрачном режиме, что мне надо еще сдалеть чтоб управлять СКУДом через локальную сеть? настройки С2000-ethernet 
тип протокола Орион Про, интерфейс 232.

Настройки settings такие же как на скрине.
Дальнейшие какие шаги? как проверить что Пульт отдает данные в АРМ???? куда копать???? 

Романов Алексей 5 месяцев 17 дней назад

События СКУД в арм видны? 

Рыбкин Евгений Сергеевич 5 месяцев 16 дней назад

Да, события стали приходить в Мониторе реагируют. Но перестали синхронизироваться ключи, и при попытке считать ключи из контроллеров выпадает ошибка 
Чтение конфигурации: Device is unknown for HwServer: Прибор не найден на интерфейсе
 

Романов Алексей 5 месяцев 13 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Добавить ответ

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

ПОКАЗАН

1820 раз

ЗАДАН

5 месяцев 26 дней назад

По каждому вопросу/ответу можно добавлять комментарии. Комментарии предназначены для уточнения вопроса/ответа.

Слева от каждого вопроса/ответа указано число – количество голосов. Над и под этим числом имеются стрелки, с помощью которых вы можете проголосовать за актуальный или понравившийся вам вопрос/ответ. Причем можете оставить свой голос как в «плюс» (верхняя стрелка), так и в «минус» (нижняя стрелка), если сообщение, например, неуместно или вы его не поддерживаете. Также можно отменить свой голос, если проголосовали ошибочно или передумали. Для отмены надо нажать на оранжевую стрелку.