партнерский раздел
ФорумИнсталляция, монтажне видно приборы в Uprog и Pprog

Инсталляция, монтаж » не видно приборы в Uprog и Pprog

Добрый день. прочитал подобные проблемы на текущем форуме но ответа на свою проблему так и не нашел. Прошу помощи у спецов. 
Что есть:
C2000M вер 3.04. (установлен адрес 10 по RS485   и адрес 7 по RS232)
сигнал 10 вер 1.12 (Адрес 1)
С2000-КПБ вер 3.02 (2шт) (адрес 2 и 4 соответственно)
С2000-СП1 вер 1.60 (адрес 3)
Проблема следующая: сам С2000М видит все приборы и работает с ними без проблем, но увидеть эти приборы с помощью программ PProg  и UProg не получается. Адреса приборов поменял через С2000М.
Подключаюсь разными способами и по RS-232 к С2000М и по RS-485 в линию. "ни ответа ни привета". Преобразователь USB-232(485) MOXA 1150. Прошел с ним огонь и воду, так что на него грешить не получится. Все настройки согласно инструкций расположенных на сайте производителя (режим - КОМПЬЮТЕР, режим ПРОГРАММИРОВАНИЯ и прочее).
Отключил все приборы и оставил только С2000М. погоды не сделало. так же программами PProg и UProg ничего не видно. Скорости сверял - совпадают. 
Но вот что странно: прогамма обновления прошивки Orion-prog видит их все и по 232 и по 485. Я даже  прошивку снизил на С2000М до 3.03, так как в программе PProg последняя версия указана 3.03. (замечание разработчикам - прибор выпустили с новой прошивкой, а программу PProg не обновили). Обновление прошивки С2000М до 3.02 тоже ничего не дало. При опросе программами Pprog и Uprog я вижу обмен данными по индикаторам Rx и Tx  на преобразователе и я вижу что во время поиска оборудования при обращении по указанным адресам я вижу ответы!!!!! но программы упорно игнорят их и указывают что ничего не найдено. Пробовал поиграть задержкой ответа - результат нулевой. В то же самое время  прогамма Orion-prog работает с полпинка и прошивает без проблем и по 232 и по 485..... Скажите в чем
 проблема??????  третий день ставлю эксперименты.

6 месяцев 11 дней назад

avatar
Если:
« ...прогамма обновления прошивки Orion-prog видит их все и по 232 и по 485... »
  Дроздов Алексей

Значит, перечитать «мануалы» и проверить настройки.
Самое оптимальное, подключиться к пульту (увидеть его), через 232, и «конфигурить» его и всё остальное.

Карпов Дмитрий 6 месяцев 10 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

23 ответа

Протокол посмотрите Орион или Орион Про, 

6 месяцев 11 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

пробоооо...ооовал и на Орионе и на Орионе ПРО. нет ответа, Сейчас подключен к одному С2000М по 232. ОпрашиваюPProg на протоколе Орион есть ответ (по индикаторам Rx и Tx интерфейса), а на Орион-Про нет ответа, но программа PProg игнорирует этот ответ и не видит ничего

6 месяцев 11 дней назад

avatar
"Переустановите" эти программы по-новой .И возьмите их с официального сайта.
 

Каргапольцев Артур 6 месяцев 11 дней назад

Во первых - почему стоит по 232 адрес 7? Ставьте 1.
Во вторых ставьте протокол Орион-Про.
В третьих Как у вас соединен преобразователь с пультом какие пины разъема преобразователя на какие входа пульта? Так как преобразователь имеет полную эмуляцию 232, а пульт имеет своеобразную (не стандартный Rx+Tx). Не стандартные пины 2+3+5, а 2+5+6(или7)
В четвертых какие настройки для 232 порта в мохе вытавлены (давайте скрин)?

Ситников Алексей Юрьевич 6 месяцев 11 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

программы сегодня с утра скачал с сайта болида.
адрес по 232 думаю погоды не делает..... ну поставлю 1 чтобы исключить "шайтана"
перепутать пины нет возможности, иначе небыло бы ответа и программа Orion-prog так же бы не видела ничего
по поводу настроек порта то тут вопрос есть.... нигле не указано про стоповые биты и проверку на четность..... есть она или нет.... ни в обной документации я не нашел. но мои эксперименты с перебором этих параметров так же не увенчались успехом

6 месяцев 11 дней назад

avatar
Настройки порта стандартные - 8, нет, 9600.
А вот настройки в ПО моха очень даже должны быть - там есть fast flush он должен быть disable (насколько помню)

Попробуйте в программе настройки портов Settings поставить галочку "Не управлять приёмопередатчиком".

Ситников Алексей Юрьевич 6 месяцев 11 дней назад

не знаю почему, но
При работе пульта С2000 или С2000М в режиме "Компьютер" адреса по RS-232 и RS-485 должны совпадать

Волков Андрей 6 месяцев 11 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

щаз попробую  посмотреть настройки мохи. а на счет адресов по 232 и 485 на форумах в других ветках я читал что они должны быть разные...... но попробую и это.
прикол в том что все это из под винды 10. сейчас пробовал из под винды 7. по 232 прога PProg увидела только С2000М и сигнал10. остальное не видно. Прога Uprog вообще ничего не увидела,  по 485 вообще тишина полная.... таже история, лампы моргают, толку нет

6 месяцев 11 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

что на данныйй момент.
Только что скачал последние дрова на МОХА (с сайта МОХА) под вин7 и вин10. переустановил. настройки порта следующие 9600 четности нет, стоповый 1, управление портом и потоком данных отключено. 
".....А вот настройки в ПО моха очень даже должны быть - там есть fast flush он должен быть disable (насколько помню)....." не влияет и с ней проболал и без нее. 
Все что удалось сделать это то что из под вин7 программой увиделись C2000М и сигнал10. остального нет......(Может их и не должно быть??????) в сети еще 
С2000-КПБ вер 3.02 (2шт) (адрес 2 и 4 соответственно)
С2000-СП1 вер 1.60 (адрес 3) + рип24 повесил как окончание шины под адресом 5 (у него есть специальная перемычка)
а вот из подд вин10 так ничего и необнаруживается

6 месяцев 11 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

у кого стоит вин10??? какой преобразователь используете???

6 месяцев 11 дней назад

avatar
два болидовских свистка usb-rs485/232. Была как-то проблема, что орион_прог не видел ничего, так там надо было  от имени администратора запустить.
случаем на сигнале-10 перемычка на интерфейсе не стоит? ну чисто случайно кто-то забыл

Волков Андрей 6 месяцев 11 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Нееее...... не стоит, на всех приборах поснимал перемычки пробовал без них, потом пробовал ставить только на крайних, потом только на одном конце, потом на другом........ пофиг.....
заметил такую штуку. программой UProg в вин7 пожно поиграться паузой ответа при обращении к конктретным приборам и она у них разная, и не постоянная, то отвевит с отной задержкой, то с другой. то вообще тишина, длина линии связи между приборами 0,5 метра. витая пара (от UTP5 одну пару вытащил и ей соединил). наводок нет. Убрал всёёёёёёё. только питание и связь осталось.....  Сигнал 10 отвечает  стабильно , остальное в разнобой и нестабильно... до С2000-СП1 вообще не достучался..... хотя опять же при обращении по адресу я вижу ответ (на преобразователе лампы Rx и ТХ), но программа его игнорит...... Такое ощущение что на входе в комп данные толи теряются, толи искажаются,  толи задерживаются..... и программа их соответственно теряет...... драйвер родной, сегодня качнул с сайта МОХА. такое ощущение что либо программа не понимает полученные данные, либо кто-то тормозит драйвер (в это плохо верится, но не понятно).

6 месяцев 11 дней назад

avatar
ну на таких длинах перемычка особо не влияет, а вообще она должна быть в начале и конце линии, если с одной стороны пульт, то перемычка тогда только в конце.

а антивирусов там никаких нету? а то иногда и они блокируют. Тот же касперский даже приостановленный, всё равно контролирует и не даёт работать (по сообщениям с этого же форума)

Волков Андрей 6 месяцев 11 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

поднял с нуля вин7, только вин7 и программы болида + драйвер на МОХА. результат тот же. Прям бедулька..... и взять другой преобразователь ради эксперимента неукого.....  блин....

6 месяцев 11 дней назад

avatar
ну когда совсем ничего не помогает, отключаем "Блочное чтение" в упроге

Волков Андрей 6 месяцев 11 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

« ... по поводу настроек порта то тут вопрос есть.... нигле не указано про стоповые биты и проверку на четность..... есть она или нет.... ни в обной документации я не нашел.... »
   Дроздов Алексей

Эти параметры в «Руководство по эксплуатации «С2000М», стр 43»:
Для RS-232/RS-485 линии связи данные со следующими параметрами:
«скорость передачи 9600 бит/с, длина слова 8 бит, без контроля четности, 1 стоповый бит.»
(«С2000М» АЦДР.426469.027 РЭ Изм. 20 АЦДР. 6293-17 от 16.12.2017)

6 месяцев 10 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Ок, гляну, видимо пропустил, спасибо.  У меня эти 5 приборов уже все глаза замылили.
 

6 месяцев 10 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Только проблему это не решает..... чуть позже  попробую убрать блочное чтение.

6 месяцев 10 дней назад

avatar
Поиск «рулит» : )
Нет связи с пультом С2000М  ( Налетов Константин )
 и так далее...

Карпов Дмитрий 6 месяцев 10 дней назад

Ну как Доздов Алексей ! На 4-й день связь наладилась?!.
 Пишите: C2000M вер 3.04. (установлен адрес 10 по RS485   и адрес 7 по RS232).
Может один адрес задать... Пурга...
Приборы подключайте по одному и смотрите в программах.Что появиться ?!.

Сергей.Ш 6 месяцев 10 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Сигнал 10 видится стабильно, С2000М из 10 попыток длстучаться до него ответ был только 1 раз. Пр этом адреса были разные. При одинаковых адресах  100% отказ связи. Хотя я же говорю что ответ вижу по индикаторам прелбразователя, но отвечает только по адресу 10 (который указан в 485), хотя подключен по 232.  Пока все указывает на МОХА или его дрова..... завтра поеду искать в ближайшем магазине другой преобразователь. Буду с ним стучаться. Болидовских ни у кого нет (в моем окружении).

6 месяцев 10 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Так и у меня преобразователь не из подвала, фирменный, официал МОХА. Поддерживаемый данным производителем. Втыкал куда угодно и все читалось и виделось, но вот с болидом что то пошло не так..... вобщем завтра видно будет.

6 месяцев 10 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Спасибо за выложенные скрины. У меня практически теже настройки, только нет редактора буфера FIFO.

6 месяцев 10 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Странно, в понедельник писал ответ, но его нет в чате. Ну да ладно, повторюсь...
В понедельник купил две свистульки блидовские USB-232 и USB-485. Подключился по 232 и 485 одновременно. Связь пошла с полпинка. Стабильно работает (считывается и программируется) как на 232, так и на 485... попробовал еще раз достучаться моксой..... не.... тишина.... может у МОХА и есть какие то скрытые настройки, которые можно корректировать,  но видимо производители их очень далеко скрыли. Поэтому делаю вывод, что МОХА явно не дружит с болидом. Моя модель МОХА 1150.

6 месяцев 7 дней назад

avatar
Да все нормально с моксой. Если брать 232 то он у них полный по стандарту в отличие от болидовского релиза (все сигналы в DB9) и нужно правильно подключать соответствующие пины.
С 485 непонятки что там у Вас.
Я многократно и часто использую НПорт для всего, и все работает.

Ситников Алексей Юрьевич 6 месяцев 7 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Алексей Юрьевич, МОХА Uport1150 подключалась и настраивалась согласно документации завода изготовителя (MOXA) к соответствующим точкам подключения С2000М указанных так же соответствующим заводом изготовителем БОЛИД. Пины были перепроверены более 10 раз.  Ни о каких нестандартных пинах 2+3+5 или 2+5+6(или7) речи быть не может. У МОХА на DB9 черным по белому в инструкции написано 2-Rx, 3-Tx, 5-GND  - это стандарт подключения на RS-232. На С2000М в инструкции черным по белому указано расположение клемм Rx, Tx, GND, а также это повторяется на самой плате (когда крышку снимите). Соответственно Rx первого прибора подключаем на Tx второго прибора и соответственно Tx первого на Rx второго. GND объединяем. По RS-485 там есть А и В соответственно А-А и В-В. Где и что тут можно напутать???? Кроме того, я же писал что Сигнал-10 читается без проблем, программа Oroin-prog работает (обнаруживает все приборы и программирует прошивки) без проблем. так что пины прошу оставить в покое, они тут не причем. Судя по разным веткам данного форума (спасибо Карпову Дмитрию)Нет связи с пультом С2000М  ( Налетов Константин )не у одного меня такая проблема с МОХА.... Вам (видимо) просто повезло с МОХА.

6 месяцев 7 дней назад

avatar
Алексей. Какой сигнал написан на плате С2000М? Там, насколько я помню DTR, а это совсем не Rx или Tx. И не важно что пишет болид в своих бумагах и на платах преобразователей, потому как мы не знаем как он эмулирует интерфейс 232 и все что он делает направлено на то чтоб покупали не моксу, а его поделки. Моха делает все по стандарту (а RS232 полностью стандартизирован).

Ситников Алексей Юрьевич 6 месяцев 7 дней назад

Tx/DTR/GND до версии пульта 2.07
Tx/Rx/gnd с версии 3.00

Батанов Александр Владимирович 6 месяцев 6 дней назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

На плате было написано Tx,Rx,GND, в инструкции на С2000М указан RS 232. Фотку прислать не могу. Оборудование уехало на объект. Про DTR нигде не указано в документации  на С2000М БОЛИД. Эксперименты ставить не с чем из-за отсутствие оборудования. Задача решена, проблема устранена. Тему данной ветки считаю закрытой. 

6 месяцев 6 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Всем участникам спасибо.

6 месяцев 6 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Во... именно такая картинка и была.... спасибо, Артур. Только версия 3.04 от 02.18
 

6 месяцев 6 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Я же говорю, у меня нет на текущий момент оборудования. Настройка закончена и оборудование уехало на объект. Эксперименты продолжу в следующий раз.

6 месяцев 6 дней назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Всем привет!

У меня близко та же ситуация: на ноуте (Win7-32) все видится - и с Моксой1150, и с C2000USB, а на рядом стоящем стационарном компе (Win7-64) ничего не находится. И, если Мокса нормально встает на комп, но ППрог с Юпрогом с ней ничего не видят, то к С2000USB просто не встает драйвер (любой из выложенных на сайте). Версии ППрога, Юпрога, драйверов Моксы, С2000ЮСБ одинаковы что на ноуте, что на компе.  

Нет ли чего нового по этому вопросу? Или дело только в 64 разрядах?

3 месяца 3 дня назад

avatar
Проверьте настройки порта программой Settings на соответствие Вашему подключению. Тип протокола (Орион, ОрионПро) и тип ПИ важны. Также проверьте, какой тип протокола выбран в Uprog и Pprog.
Есть маленькая хитрость, OrionProg игнорирует настройки сом-порта, поэтому часто "видит" аппаратуру, которая не обнаруживается другими программами. Проверьте видит ли OrionProg аппаратуру.
И ещё, если на проблеммном компе установлен антивирь (kaspersky например), то он также может мешать закрывая порты обмена.

Налетов Константин 3 месяца 3 дня назад

Насчет неставящихся драйверов. Имел проблему с программатором для домофона, может и здесь та же фигня. Нагугливаем "отключение режима проверки драйверов" и делаем по инструкции. Там несколько разных вариантов действий, наверное, для разных сборок. Там, где семёрка писала "Этот драйвер не тестировался на совместимость, хотите продолжить?" восьмерка и десятка требуют танцев с бубном действий на 6.

Крамаров Павел 3 месяца назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Константин, спасибо!
OrionProg увидел сразу, а ППрог и UProg после передергивания значений протокола, преобразователя. В начале стояло как бы все верно, но помогло переключение в неверные параметры, а затем обратно как было.
Характерно, что т/поддержка Болида (звонил им предварительно) однозначно сказала, что дело в моей МОКСЕ-1150, и что настройки порта никак не влияют при прямом подключении к компу.
 

3 месяца 3 дня назад

avatar
Тут все может еще быть в правах пользователя при установке программ (даже от имени администратора. особенно на десятке - вот мнительная зверюга). Винда банально не разрешает при установке прописывать параметры в реестр. Поэтому программа вроде бы отображает верные параметры но в реестре данные об этом отсутствуют (а это косяк программы). И соотвественно драйвер с портом не могут взять требуемые параметры из реестра куда их посылает программа.

Ситников Алексей Юрьевич 3 месяца 2 дня назад

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

С МОХА 1150 мучался. Причём, всё как описано топикстартером. Настроил всё через другой, а через моксу оставил работать Орион про - без проблем.

3 месяца 1 день назад

avatar
Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

Добавить ответ

Для добавления сообщений на форуме вам необходимо зарегистрироваться и указать мобильный телефон в своем профиле (зачем?)

ПОКАЗАН

2432 раза

ЗАДАН

6 месяцев 11 дней назад

ПРОДУКТЫ

Orion-Prog
PProg
UProg

По каждому вопросу/ответу можно добавлять комментарии. Комментарии предназначены для уточнения вопроса/ответа.